ubuntu/debian系统下vestacp升级php7

2016年4月22日23:26:08 8 1,714

ubuntu/debian系统下vestacp升级php7

vestacp安装教程,可以参考“VPS新手教程:一键安装LNMP/LAMP/LANMP环境之Vestacp”,这里主要说的是把php版本升级到7,系统是ubuntu/debian。

 

第一,我们查看下当前你安装的vestacp里面的php版本:

SS客户端里输入:php -v

一般会看到:PHP 5.6.xx 和 Zend Engine v2.6.xx

 

第二,删除PHP

输入:apt-get -y purge php5

 

第三,安装一些组件:

输入:apt-get install python-software-properties

 

第四:继续安装组件

add-apt-repository ppa:ondrej/php-7.0

apt-get update

 

第五:安装php7

apt-get install -y php7.0

 

第六:检查现在php版本

php -v

一般来说已经是:PHP 7.0.x , Zend Engine v3.0.x

 

第七:为了用的顺手我们再安装点儿php的组件

apt-cache search php7-*

 

现在你可以选择一些你需要的了,比如:

apt-get install php7.0-common libapache2-mod-php7.0 php7.0-cgi php7.0-cli php7.0-phpdbg php7.0-fpm libphp7.0-embed php7.0-dev php7.0-dbg php7.0-curl php7.0-gd php7.0-imap php7.0-interbase php7.0-intl php7.0-ldap php7.0-mcrypt php7.0-readline php7.0-odbc php7.0-pgsql php7.0-pspell php7.0-recode php7.0-tidy php7.0-xmlrpc php7.0 php7.0-json php-all-dev php7.0-sybase php7.0-modules-source php7.0-sqlite3 php7.0-mysql php7.0-opcache php7.0-bz2

 

第八,启动php-fpm

service php7.0-fpm start

 

第九:删除旧版的symblink,创建个新的

rm /usr/bin/php

ln -s /usr/bin/php7.0 /usr/bin/php

 

第十:重启apache

service apache2 restart

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:8   其中:访客  6   博主  2

    • Python Swift Python Swift 6

      centos的有这样方便的么

        • akw28888 akw28888 6

          理論上可以換成epel源的php7 可以試試看。
          http://www.servermom.org/upgrade-vestacp-to-php-7-centos/2974/
          參考這一個。

        • 文武双全 文武双全 5

          php7.0-gd 这个东西,你确定有?

            • gongyi gongyi Admin

              https://packages.debian.org/sid/php7.0-gd 你是在说这个么?

            • chro chro 4

              很多时候新的不一定是好的,还是选择已经千锤百炼的5.x吧。只是玩玩的话无所谓

                • gongyi gongyi Admin

                  坐等吧,我暂时还没有升级到7,等半年再说!

                • Jasn Jasn 0

                  到第四步出现cannot access ppa,求指教